Diffuser Issues - DIY Aquarium Projects - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > DIY Aquarium Projects

DIY Aquarium Projects For those that are handy or looking to save some money, discuss your DIY aquarium projects here.

Reply
 
LinkBack Thread Tools Display Modes
Old 03-05-2007, 11:20 AM   #1 (permalink)
Junior Member
 
Join Date: Apr 2006
Posts: 1
iTrader Ratings: 0
peternevins is a regular member
:
Default Diffuser Issues

So last week I accidentally knocked over my 1 leader CO2 bottle going into my 5 gal nano, it started to fizz like crazy and pushed through the tube and filled the diffuser with a milky yeast, sugar water solution, the pressure made the bubbles go like crazy and then stop all together. I took the diffuser out and put it on the heater in my room, allowing all the liquid to evaporate out. But after a few days there is still no CO2 coming out, and because of this Iíve got one hell of an angle bloom, the inside of the diffuser looks like it has dried up yeast water solution on its sides, could this also be blocking the pours in the ceramic and how can I clean it out? Or is it something else?
Thanks a lot, -Colin
peternevins is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in Technorati
Reply With Quote

Advertisement [Remove Advertisement]
Old 03-05-2007, 11:37 AM   #2 (permalink)
Senior Member
 
redstrat's Avatar
 
Join Date: Apr 2006
Location: Columbus, OH
Posts: 1,082
iTrader Ratings: 39
iTrader Positive Rating: 100%
redstrat is a valuable member of the communityredstrat is a valuable member of the community
:
Default

I've heard bleach is one of the best ways to clean diffusors, sounds like this one needs a good cleaning inside and out. Soak it for while then give it a good rinse and it should ready to go. This is what i've heard though I haven't had to try it yet. good luck
redstrat is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in Technorati
Reply With Quote
Old 03-05-2007, 12:54 PM   #3 (permalink)
Senior Member
 
eklikewhoa's Avatar
 
Join Date: Jul 2006
Location: Houston,TX
Posts: 1,946
iTrader Ratings: 16
iTrader Positive Rating: 100%
eklikewhoa is a regular member
:
Default

Bleach solution or hydrogen peroxide works but you will have to let it soak so that it gets inside and then soak it in some de-chlor.
eklikewhoa is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in Technorati
Reply With Quote
Reply


Aquatic Plant Central > General Interest Forums > DIY Aquarium Projects > Diffuser Issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Aquatic Plant Forum Replies Last Post
A few plant issues new2tanks New to Planted Aquariums 2 07-08-2006 05:22 PM
Moss issues molurus73 South Western Ohio Aquatic Plant Enthusiasts 6 09-30-2005 06:28 AM
A few issues I need help with. JaySilverman General Aquarium Plants Discussions 15 07-23-2005 06:46 PM
Having a few issues. Need some advice RedDelPaPa General Aquarium Plants Discussions 4 07-05-2005 12:00 AM


All times are GMT -8. The time now is 03:03 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.5.2