Unable to remove algae - Algae - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > Algae

Algae Algae Control - Get some advice for your algae problems. Control algae in your aquarium with the solutions given here.

Reply
 
LinkBack Thread Tools Display Modes
Old 05-14-2020, 11:21 AM   #1 (permalink)
Junior Member
 
Join Date: Dec 2018
Posts: 3
iTrader Ratings: 0
bugpb60 is a regular member
Unhappy Unable to remove algae

Hello,

I am unable to remove an algae since few month in my aquarium.
300L, chihiros A plus 40% of 19200 lumens = 7680lumens, injecting co2 1 bubble each second., inject NO3, Easy carbo.
My parameters : PH=7.4, Fe=0,NO3=10-15,PO4=0.

Can you help me to identify what is this algae ?







Last edited by bugpb60; 05-14-2020 at 01:10 PM..
bugpb60 is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 05-15-2020, 02:33 PM   #2 (permalink)
Senior Member
 
mistergreen's Avatar
 
Join Date: Mar 2007
Posts: 1,487
iTrader Ratings: 0
mistergreen is a regular member
Default Re: Unable to remove algae

I think it's the start of Black beard. It's best to trim the affected leaves. Squirting H2O2 on the wood might help.
mistergreen is offline   Reply With Quote
Old 05-17-2020, 04:06 AM   #3 (permalink)
Junior Member
 
Join Date: Jul 2019
Posts: 3
iTrader Ratings: 0
CarissaT is a regular member
Default Unable to remove algae

Are you dosing potassium, phosphate and micros? If not your plants are likely starving and algae are just taking advantage of weak plants.

Sent from my iPad using Tapatalk
CarissaT is offline   Reply With Quote
 
Old 05-22-2020, 01:29 PM   #4 (permalink)
Junior Member
 
Join Date: Dec 2018
Posts: 3
iTrader Ratings: 0
bugpb60 is a regular member
Default Re: Unable to remove algae

Thanks. I don't think it is BBA algae because the algae is short hairy and green.
I push N and Easy carbo each day with a dosing pump.

Since this week, i push now Phosphate and micro too. (Aquarebell)
bugpb60 is offline   Reply With Quote
Reply

« Staghorne algae | - »

Aquatic Plant Central > General Interest Forums > Algae > Unable to remove algae

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:03 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1