Go Back   Aquatic Plant Central > Aquarium Pictures > Plant Deficiency Symptoms

Home What's New Upload Search

« Previous Image   |   Next Image »
Non-deficiency, damage Image Tools
Non-deficiency, damage
Filmstrip
Non-deficiency transplation damage
‹‹
Non-deficiency, damage
Non-deficiency, damage
 
Non-deficiency, damage
10-27-2007 10:36 PM
Description: This is a pic of my Echinodorus Grandiflorus
Posted By: voytek333 (View all of voytek333's images) Dimensions: 600 x 450 (2272 x 1704)
Views: 4,936 Filesize: 187.5 KB (827.5 KB)
Keywords: Grandiflorus
Camera Information
Make: Canon Model: Canon PowerShot SD300
Orientation: 1 XResolution: 180/1
YResolution: 180/1 ResolutionUnit: 2
DateTime: 2007:10:25 14:28:35 YCbCrPositioning: 1
XResolution: 180/1 YResolution: 180/1
ResolutionUnit: 2 ExposureTime: 1/60
CompressedBitsPerPixel: 3/1 ExposureBiasValue: 0/3
MaxApertureValue: 95/32 MeteringMode: 5
Flash: 25 FocalLength: 5800/1000
FlashPixVersion: 0100 DigitalZoomRatio: 2272/2272
InterOperabilityIndex: R98

Image Tools
Printable Version
Report to Moderator

Replies to Image: Non-deficiency, damage
10-28-2007, 03:08 AM   #1
sandibeda
 
Join Date: Oct 2007
Posts: 0
iTrader Ratings: 0
sandibeda is a regular member
Default

Looks like you could do with a good fertilizer, if you dont use fertilizer. If you do, then it must be something else, but before I used fertilizer I had some leaves that looked the same. After I began to fertilize reguarly I dont get this problem anymore.
Greetings Beda (sandi)
sandibeda is offline Report Post  

Advertisement [Remove Advertisement]
10-28-2007, 11:46 PM   #2
voytek333
Member
 
Join Date: May 2006
Posts: 49
iTrader Ratings: 4
iTrader Positive Rating: 100%
voytek333 is a regular member
Default Re: Somebody ID this deficiency ?

Quote:
Originally Posted by sandibeda
Looks like you could do with a good fertilizer, if you dont use fertilizer. If you do, then it must be something else, but before I used fertilizer I had some leaves that looked the same. After I began to fertilize reguarly I dont get this problem anymore.
Greetings Beda (sandi)

thank you for the reply - and oh yes I do fertilize quite a lot actually ... but I can't find the missing nutrient for this plant - I recently doubled the Potassium and Phosphate doses and it's a little better. Thanks to the plant I can see it improve or get bad very fast since it has new leaf every 3-4 days !!! I love my ECHINODORUS GRANDIFLORUS = )


take care
voytek333 is offline Report Post  
04-25-2008, 07:25 PM   #3
Greenleaves420
 
Join Date: Apr 2008
Posts: 23
iTrader Ratings: 0
Greenleaves420 is a regular member
Default

i have the same problem with this same plant....... i have tried alot of things but now i have like one little dieing leaf left.....sad...all my other plant are growin like crazy cept this and one other
Greenleaves420 is offline Report Post  

Category Jump

Powered by PhotoPost vBGallery v2.4.3

All times are GMT -8. The time now is 09:11 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1