What's the worst purchase you ever made? - Page 2 - Equipment - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > Equipment

Equipment Aquarium Equipment - Discuss equipment to help setup your planted aquarium.

Reply
 
LinkBack Thread Tools Display Modes
Old 02-22-2004, 07:58 PM   #11 (permalink)
Senior Member
 
ryuken168's Avatar
 
Join Date: Feb 2004
Location: Big Apple NYC
Posts: 179
iTrader Ratings: 0
ryuken168 is a regular member
Default

Emperor 400 ??? I love my bio-wheel, I think they work well besides the priming problem, but only good for fish tanks.
The worst filter I brought was the Whisper 3.
Besides that the JBJ algae magnet and the JBJ 2 way powerhead is also on top of my worst list and of cost the plastic plants.
ryuken168 is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 02-24-2004, 09:58 AM   #12 (permalink)
Senior Member
 
jerseyjay's Avatar
 
Join Date: Jan 2004
Location: North Jersey
Posts: 810
iTrader Ratings: 9
iTrader Positive Rating: 100%
jerseyjay is a regular member
Default

Quote:
Originally Posted by ryuken168
Emperor 400 ??? I love my bio-wheel, I think they work well besides the priming problem, but only good for fish tanks.
Exactly Ken.
I was giving my review from plant-geek perspective. Works like a charm on my Malawi Lake tank, but counter-productive in planted tanks.
jerseyjay is offline   Reply With Quote
Old 02-24-2004, 11:53 AM   #13 (permalink)
Member of SCAPE
 
Join Date: Feb 2004
Location: San Juan Capistrano, CA
Posts: 884
iTrader Ratings: 3
iTrader Positive Rating: 100%
IUnknown is a regular member
Default

Automatic Water Change System. Never really got it going.
IUnknown is offline   Reply With Quote
 
Old 02-24-2004, 01:03 PM   #14 (permalink)
Senior Member
 
Join Date: Feb 2004
Location: USA
Posts: 739
iTrader Ratings: 1
iTrader Positive Rating: 100%
gpodio is a regular member
Default

For me it has to be AmQuel, after more than 10 years of using Tetra Aquasafe for some stupid reason I decided to give AmQuel a shot. Killed all my apistos and rams in one day

Disclaimer: it was obviously due to heavy metals in my tap water than AmQuel is not supposed to fix. Perhaps that was the most "stupid" purchase come to think of it

Giancarlo Podio
gpodio is offline   Reply With Quote
Old 02-24-2004, 01:32 PM   #15 (permalink)
 
Join Date: Feb 2004
Posts: 20
iTrader Ratings: 0
ginnie5 is a regular member
Default tap water purifier...

when I first started keeping a tank I thought it would help with my liquid rock. I should've invested in an ro unit instead. I ended up tossing it when we moved. It was a pain and I had to change the inserts constantly. thanksfully I have wonderfully soft water now. Now all I have to do is add baking soda to keep the kh up!
ginnie5 is offline   Reply With Quote
Old 02-24-2004, 10:47 PM   #16 (permalink)
Junior Member
 
Justin Fournier's Avatar
 
Join Date: Jan 2004
Location: Vancouver BC, Canada
Posts: 4
iTrader Ratings: 0
Justin Fournier is a regular member
Default

I have used plenty of Red Sea test kits, P04 always worked great. Fe never worked great..... I wonder if it's operator error? Perhaps the color charts were read wrong or something......

Worst thing I ever bought was glass tops made by Hagen, specifically the ones for non-centerbraced tanks, with thier own plastic centerbrace...
Justin Fournier is offline   Reply With Quote
Old 03-04-2004, 10:14 PM   #17 (permalink)
Senior Member
 
Join Date: Feb 2004
Posts: 302
iTrader Ratings: 1
iTrader Positive Rating: 100%
nonamethefish is a regular member
Default

Whats so bad about Whisper filters? Im guessing its cause they are HOB?

I've got an emperor runnign on my 46 gallon bowfront. Even if you arent injecting Co2, is that a bad thing?
nonamethefish is offline   Reply With Quote
Old 03-05-2004, 08:26 AM   #18 (permalink)
 
Join Date: Mar 2004
Posts: 19
iTrader Ratings: 0
sergioveterano is a regular member
Default

I've boght a substrat cleaner, i've used one time.
sergioveterano is offline   Reply With Quote
Old 03-31-2004, 09:40 AM   #19 (permalink)
 
Join Date: Mar 2004
Posts: 302
iTrader Ratings: 0
hubbahubbahehe is a regular member
Default

My stupidest purchase was a canister filter that had a clip missing..... being a canister virgin, i had no idea that it would leak A TON of water into my house.....fellas if you are going to buy a canister filter used, make sure it has all the clips!!!! the dishonest seller might not even warn you about it!!!!
hubbahubbahehe is offline   Reply With Quote
Old 03-31-2004, 10:24 AM   #20 (permalink)
 
Join Date: Mar 2004
Posts: 143
iTrader Ratings: 0
aquoi is a regular member
Default

Airstone (forgot the brand), no air comes out...
aquoi is offline   Reply With Quote
Reply


Aquatic Plant Central > General Interest Forums > Equipment > What's the worst purchase you ever made?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Aquatic Plant Forum Replies Last Post
I made it, I really found my way here! Neptun Introductions and Greets 2 12-18-2004 06:39 PM
aquasvcape made in the ISRAEL freshreef Aquascaping 1 11-24-2004 08:26 AM
Help in purchase of regulator and Ph contoller combo. Please TRI916 For Sale or Trade 1 09-04-2004 01:37 PM
What's the BEST purchase you ever made? Justin Fournier Equipment 13 04-06-2004 08:37 AM


All times are GMT -8. The time now is 02:55 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1