Aquatek Co2 Regulator/Solenoid Issue - Equipment - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > Equipment

Equipment Aquarium Equipment - Discuss equipment to help setup your planted aquarium.

Reply
 
LinkBack Thread Tools Display Modes
Old 02-17-2021, 07:39 AM   #1 (permalink)
Junior Member
 
Join Date: Feb 2021
Posts: 2
iTrader Ratings: 0
Bodul67 is a regular member
Default Aquatek Co2 Regulator/Solenoid Issue

I have the AQUATEK Aquarium CO2 Regulator with Integrated COOL TOUCH Solenoid. It's on a timer to turn on & off at specific times. When the timer switches off, the solenoid sticks in the open position. I have to unplug & plug it back in multiple times before the solenoid closes. I unscrewed the solenoid from the brass regulator and found that the rubber O-Ring has been torn slightly and that's the reason the solenoid wouldn't close properly. I reached out to Aquatek about a replacement O-Ring and they replied by I need to order a new solenoid. Of course they would, they want me to pay $40 for a new solenoid rather than pay less than $1 for a new O-Ring. Horrible!!!

Has anyone had this same problem and how was it rectified? I can't seem to find the exact O-ring to replace. I found one at Lowes and it's 5/16" ID x 1/16" CS, but it's too thick. The CS is half the thickness around 1/32" that I need.

The picture below is the O-ring that I'm talking about. It's NOT a picture of the torn one that I have, it's just a reference to location of O-Ring.
Attached Thumbnails
Click image for larger version

Name:	Aquatek.jpg
Views:	3
Size:	7.9 KB
ID:	65131  
Bodul67 is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 02-17-2021, 09:36 AM   #2 (permalink)
Moderator
 
hoppycalif's Avatar
 
Join Date: Apr 2005
Location: Brentwood, CA, USA
Posts: 7,415
iTrader Ratings: 22
iTrader Positive Rating: 100%
hoppycalif is a valuable member of the community hoppycalif is a valuable member of the community hoppycalif is a valuable member of the community
Default Re: Aquatek Co2 Regulator/Solenoid Issue

You could try getting an O-ring selection from Amazon, like https://www.amazon.com/Assortment-Se...583188&sr=8-13 I can't tell if any of them would fit, but it would cost a lot less than $40. Try measuring the thickness of the ring in mm instead of inches, and you can figure out if any of these would fit.
hoppycalif is offline   Reply With Quote
Old 02-17-2021, 10:59 AM   #3 (permalink)
Senior Member
 
mistergreen's Avatar
 
Join Date: Mar 2007
Posts: 2,130
iTrader Ratings: 0
mistergreen is a regular member
Default Re: Aquatek Co2 Regulator/Solenoid Issue

I'm not sure if that exterior o-ring is the cause for the solenoid sticking. Try plugging and unplugging it to test. You should hear clicking sounds where the magnet fires up.
mistergreen is online now   Reply With Quote
 
Old 02-22-2021, 06:05 AM   #4 (permalink)
Junior Member
 
Join Date: Feb 2021
Posts: 2
iTrader Ratings: 0
Bodul67 is a regular member
Default Re: Aquatek Co2 Regulator/Solenoid Issue

The O-Ring had a little torn piece hanging off and looks like it was jamming the piston from moving. I found new O-rings which are 8mmx10mmx1mm and waiting for delivery. I also lubricated the piston with a drop of WD40 and for the past 3 days seems to be working fine now.
Bodul67 is offline   Reply With Quote
Old 02-22-2021, 03:38 PM   #5 (permalink)
Junior Member
 
maico996's Avatar
 
Join Date: Nov 2016
Location: Puyallup WA
Posts: 28
iTrader Ratings: 0
maico996 is a regular member
Default Re: Aquatek Co2 Regulator/Solenoid Issue

Quote:
Originally Posted by Bodul67 View Post
The O-Ring had a little torn piece hanging off and looks like it was jamming the piston from moving. I found new O-rings which are 8mmx10mmx1mm and waiting for delivery. I also lubricated the piston with a drop of WD40 and for the past 3 days seems to be working fine now.
WD40 isn't really a lubricant. The "WD" stands for "water displacing". It's a solvent and a rust dissolver and will do more to dry things out. You'd be better off using a silicone or Teflon lubricant.

Last edited by maico996; Yesterday at 04:19 PM..
maico996 is online now   Reply With Quote
Reply


Aquatic Plant Central > General Interest Forums > Equipment > Aquatek Co2 Regulator/Solenoid Issue

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:50 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1