eheim 2026 - Noisy - Quick Help Please - Equipment - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > Equipment

Equipment Aquarium Equipment - Discuss equipment to help setup your planted aquarium.

Reply
 
LinkBack Thread Tools Display Modes
Old 03-25-2006, 06:45 PM   #1 (permalink)
 
Join Date: Mar 2006
Posts: 60
iTrader Ratings: 0
Bombay is a regular member
Default Calling all eheim pimps - more troubles!!!

Edited: Calling all Eheim Pimps...more problems!!!

I bought an eheim probably back in 2000. I set it up along with another filter...too much for the tank and NOISY. I read some of the posts talking about the flow ball rattling, but this is not that noise. Having a Emp 400, I know what impeller noise is, and this is it.

I just set this filter up again (the eheim) and it is noisy...impeller noisy. So, I took the impeller cover off and slid the impeller out. I looked at the diagram on page 24 (image 39). It shows the impeller, the shaft, and a rubber bumper on each side. I noticed right away that my impeller only has 1 bumper. Does anyone know if they are supposed to come with 2 or 1?

It seems to me that the noisy impeller would be caused by this...since the other impellers i've seen have two bumpers. Any suggestions?

(Note, this was a brand new filter when I purchased it and I have never removed the impeller before)

Last edited by Bombay; 03-26-2006 at 05:04 AM.. Reason: New info, more problems
Bombay is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 03-25-2006, 11:48 PM   #2 (permalink)
NE
 
Join Date: Dec 2004
Posts: 162
iTrader Ratings: 0
NE is a regular member
Default

There should be one rubber bumper in each end, but sometimes it does not come out with the shaft, some times it stays in the holder cup instead. If there is only one then you have found the problem.

The two other common causes for noise are:
1. Air in the pump chamber
2. Worn-out shaft or impeller which makes it fit bad to each other and rattles (but i guess thats not the case here)
NE is offline   Reply With Quote
Old 03-26-2006, 01:30 AM   #3 (permalink)
Senior Member
 
Join Date: Dec 2004
Location: Cologne, Germany
Posts: 110
iTrader Ratings: 0
detlef is a regular member
Default

Hi ,

I also own an Eheim 2026 which was so noisy (even called Eheim for help with no success) I replaced it by my old Eheim 2224. Less water flow and less media but so quiet I hardly can hear the pump at all with my ears close to the canister. Much better designed than the new model! I really would like Eheim to produce big filters with less noise. Anyone out there with a quiet 2026? Sorry Bombay can't help you.

Regards,
Detlef

Last edited by detlef; 03-26-2006 at 01:45 AM..
detlef is offline   Reply With Quote
 
Old 03-26-2006, 01:39 AM   #4 (permalink)
NE
 
Join Date: Dec 2004
Posts: 162
iTrader Ratings: 0
NE is a regular member
Default

I cant agree with that i have a lot of different Eheim pumps and filters and i think all of them are very quiet.

I have one 2128 which is basically the same as 2026 (a bit bigger and with heater) and its very quiet, the only sound is a quiet hum if i place my ear close to it.
NE is offline   Reply With Quote
Old 03-26-2006, 02:31 AM   #5 (permalink)
Senior Member
 
Join Date: Dec 2004
Location: Cologne, Germany
Posts: 110
iTrader Ratings: 0
detlef is a regular member
Default

Sorry NE,

I my living room I sit close to the canister (only 1 meter away) and I could not stand the noisy but brand new! 2026. May be these Eheims suffer from differences in production precision? I don't know. I suspect the pump mechanism for filling the canister with water. Rattle and hummmmmmm ...

Regards,
Detlef
detlef is offline   Reply With Quote
Old 03-26-2006, 03:04 AM   #6 (permalink)
NE
 
Join Date: Dec 2004
Posts: 162
iTrader Ratings: 0
NE is a regular member
Default

Dont be sorry, i guess we all might have different experience with a lot of things, but I like Eheim and have had extremely little problems with their products.

There are production updates, my old Pro W&D had major problems with the floating device, but Eheim remade it and after the update it worked like a charm.
Also in ProII I guess there has at least been some kind of update for the flow indicator, which many people reports have been making noise (mine does not, I have the "new" type).

I dont like the starter pump / mechanism at all, maybe i'm stupid but i have a lot of problem every time i have done something with the filter, as i understand it the output hose has to be completely emptied from water to make this work?
NE is offline   Reply With Quote
Old 03-26-2006, 03:04 AM   #7 (permalink)
 
Join Date: Mar 2006
Posts: 6
iTrader Ratings: 0
oliver_p is a regular member
Default

Hi,

I have a 2026 running for some weeks and had a 2226 before. The noise level is comparable (low) but the overall build quality of the new 2026 seems to be lower. Maybe this causes more noise due to production spread in some cases...

Best regards,
Oliver
oliver_p is offline   Reply With Quote
Old 03-26-2006, 05:00 AM   #8 (permalink)
 
Join Date: Mar 2006
Posts: 60
iTrader Ratings: 0
Bombay is a regular member
Default

Thanks NE, but the saga continues.

So here is the concern, question or observation...or all three. As I mentioned, I set this filter up for a few days back in 2000. Too loud. Took it down, packed it up and there is sat for several years in the original box up in the closet in an air conditioned home.

First, I checked the cavity where the 2nd bumper would sit...nothing there. This really infuriates me since I have never removed the impeller!

2nd, I woke up last night to the unmistakeable sound of water exiting from somewhere. I jumped up in bed...but a glance at my tank...and a glance at the floor put my mind at rest. I told myself that the extra air caught up in the media was being cleared. What a mistake!

I opened the cabinet this morning and it looks like my tank lost about a gallon last night. I checked the hoses, nothing. I checked the tank seams, nothing. I disconnected the filter and brought it to the kitchen. It was the filter that had leaked.

When I unfastened the clips this morning, and turned the motor portion upside down, I noticed that water was pouring from the round primer button area. Is this normal? I thought this area would be sealed?!?! Now, I did continue to "prime" the filter last night once I had it running. I did this since I thought it might release extra air...and thus quiet the noise. Extra air was released. By doing this, did I not allow the primer seal to...well...to seal again? Or is the seal on the primer button defective...or is there something else wrong?

Help! I've never had any luck with this eheim 2026! This is not the case with any of my other filters (mostly hob)...that includes a Magnum 350 canister...which has worked flawlessly.
Bombay is offline   Reply With Quote
Old 03-26-2006, 05:07 AM   #9 (permalink)
 
Join Date: Mar 2006
Posts: 60
iTrader Ratings: 0
Bombay is a regular member
Default

Has anyone had experience in dealing with eheim directly? I purchased this filter from a reputable online retailer, but that was 4-6 years ago. I am sure they will not believe my story about the missing rubber bumper. Anyone have a suggestion on how I might obtain one? Based on looking up the impeller part on thatpetplace.com, the impeller doesn't come with the shaft or bumpers.
Bombay is offline   Reply With Quote
Old 03-26-2006, 05:42 AM   #10 (permalink)
NE
 
Join Date: Dec 2004
Posts: 162
iTrader Ratings: 0
NE is a regular member
Default

Sorry to hear about all your problems.

Anyone that sells Eheims should be able to at least get it for you.
It seems that you could order directly from Eheim, and the bumper seems to be a part of the spare shaft.

http://www.eheimparts.com/client/homepage.aspx

Last edited by NE; 03-26-2006 at 05:45 AM..
NE is offline   Reply With Quote
Reply


Aquatic Plant Central > General Interest Forums > Equipment > eheim 2026 - Noisy - Quick Help Please

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Aquatic Plant Forum Replies Last Post
eheim 2028 pro 2 or eheim 2026 pro 2 jamesbrokman10 Equipment 3 11-23-2005 11:46 PM
XP2 or Eheim 2026? milalic Equipment 6 09-01-2005 09:51 AM
Eheim user opinions... Bert H Equipment 5 02-24-2005 12:13 PM
Eheim 2026 paul236313 Equipment 1 08-28-2004 08:01 PM
eheim substrate paul236313 General Aquarium Plants Discussions 2 08-16-2004 03:41 PM


All times are GMT -8. The time now is 12:12 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1