Eheim hose connector stuck - Equipment - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > Equipment

Equipment Aquarium Equipment - Discuss equipment to help setup your planted aquarium.

Reply
 
LinkBack Thread Tools Display Modes
Old 07-30-2011, 08:02 AM   #1 (permalink)
Senior Member
 
Join Date: Oct 2009
Posts: 174
iTrader Ratings: 0
Glaucus is a regular member
Default Eheim hose connector stuck

I have a bit of a problem with my Eheim 3 canister filter. The hose connector that clicks in seems to be somehow stuck. When I push the Red Release Button it will not release the hose connector. Also i noticed a grinding noise which i never before heard. Need some help here.

Last edited by Glaucus; 07-30-2011 at 08:19 AM..
Glaucus is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 07-30-2011, 08:28 AM   #2 (permalink)
Senior Member
 
Join Date: Feb 2006
Location: Tennessee
Posts: 342
iTrader Ratings: 12
iTrader Positive Rating: 100%
jeff5614 is a regular member
Default Re: Eheim hose connector stuck

I have a Pro 3 and noticed mine was getting harder to remove so I lubed the two rubber gaskets which fixed it. Of course this won't help you remove it, but it will remedy it if you can get it out.
jeff5614 is offline   Reply With Quote
Old 07-30-2011, 09:35 AM   #3 (permalink)
Senior Member
 
Join Date: Oct 2009
Posts: 174
iTrader Ratings: 0
Glaucus is a regular member
Default Re: Eheim hose connector stuck

Thanks for the tip. Meanwhile still didn't get the release button to work and there does not seem to be another way to release it. More tips are welcome.
Glaucus is offline   Reply With Quote
 
Old 07-30-2011, 11:57 AM   #4 (permalink)
Senior Member
 
Join Date: Feb 2006
Location: Tennessee
Posts: 342
iTrader Ratings: 12
iTrader Positive Rating: 100%
jeff5614 is a regular member
Default Re: Eheim hose connector stuck

Maybe give Eheim a call? 1-888-Eheim-NA

Stupid question but have you tried pulling it out as you press the release button? If it's stuck maybe a little extra coaxing could help.
jeff5614 is offline   Reply With Quote
Old 08-02-2011, 07:37 AM   #5 (permalink)
Senior Member
 
Join Date: Oct 2009
Posts: 174
iTrader Ratings: 0
Glaucus is a regular member
Default Re: Eheim hose connector stuck

The release button had miraculously started working again and allowed me to solve the problem. On maintenance i apparently had fitted the float bracket improperly. The white plastic piece was placed upside down. Grinding noise is over and releasing the hose won't be a problem anymore either.
Glaucus is offline   Reply With Quote
Old 01-22-2012, 06:48 AM   #6 (permalink)
Senior Member
 
Join Date: Oct 2009
Posts: 174
iTrader Ratings: 0
Glaucus is a regular member
Default Re: Eheim hose connector stuck

Hmm. Problem actually got worse. The adapter gave up all together. Not only can i not release the adapter but the on/off switch is completely loose too. So its out of order now. This should not happen with a pump this costly. Anyway need to get a heater asap.
Glaucus is offline   Reply With Quote
Old 01-26-2012, 01:17 PM   #7 (permalink)
Senior Member
 
Join Date: Feb 2006
Location: Tennessee
Posts: 342
iTrader Ratings: 12
iTrader Positive Rating: 100%
jeff5614 is a regular member
Default Re: Eheim hose connector stuck

If it's still under warranty contact Eheim about replacing it.
jeff5614 is offline   Reply With Quote
Old 01-27-2012, 08:07 AM   #8 (permalink)
Senior Member
 
Join Date: Oct 2009
Posts: 174
iTrader Ratings: 0
Glaucus is a regular member
Default Re: Eheim hose connector stuck

Quote:
Originally Posted by jeff5614 View Post
I have a Pro 3 and noticed mine was getting harder to remove so I lubed the two rubber gaskets which fixed it. Of course this won't help you remove it, but it will remedy it if you can get it out.
Hi jeff,
You were right all along. After the last time it got stuck i did not lube the adapter convinced it was because of the misfitted float bracket and because of the fact that none of my other eheims needed lubrication. However lack of lube was indeed what caused the mechanism to grind to a halt. Now the adapter has been forcefully removed (involving unscrewing and a saw). Its been replaced by a new adapter and lubed with eheim spray.

Unfortunately eheim does not provide any warranty on the parts made out of plastics only ceramic parts and the motor; at least thats what i was told by the reseller.

-Glaucus
Glaucus is offline   Reply With Quote
Reply


Aquatic Plant Central > General Interest Forums > Equipment > Eheim hose connector stuck

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:43 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1