[Wet Thumb Forum]-Newbie question..help! and Hi! :) - General Aquarium Plants Discussions - Aquatic Plant Central

Go Back   Aquatic Plant Central > General Interest Forums > General Aquarium Plants Discussions

General Aquarium Plants Discussions Discuss aquarium plants, aquatic environments, aquarium lighting, aquarium filters, aquarium backgrounds, and other aquarium topics.

Reply
 
LinkBack Thread Tools Display Modes
Old 12-26-2003, 02:23 PM   #1 (permalink)
 
Join Date: Dec 2003
Posts: 0
iTrader Ratings: 0
jazfish is a regular member
Default

Hi all.. just found this site and hope you can help. I have a new tank - 55 gallons, been set up for just a couple of weeks now. I have 3 plants - a sword (not sure what type), anacharis, and a java fern. On all plants, there is a white fuzz... I would call it fuzz algae except its white, not green. (is there such a thing as white algae?) The fish are fine (white clouds, zebras, and a couple albino cory's is all thats in there right now) and not much of the white stuf on the gravel or rocks.

Any idea what this stuf is? And if it's bad stuf, what do i do to get rid of it?

Water ph is around 7.0 to 7.2 (seems to vary slightly), water hardness is at 5, nitrates and ammonia are nil. Anything else i should test for? Ive been trying to find references to this stuf on the net, but havent found much.

Your help is much appreciated! Im new to all this... and i see there is SO much to learn!

Thanx again.
jazfish is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 12-26-2003, 02:23 PM   #2 (permalink)
 
Join Date: Dec 2003
Posts: 0
iTrader Ratings: 0
jazfish is a regular member
Default

Hi all.. just found this site and hope you can help. I have a new tank - 55 gallons, been set up for just a couple of weeks now. I have 3 plants - a sword (not sure what type), anacharis, and a java fern. On all plants, there is a white fuzz... I would call it fuzz algae except its white, not green. (is there such a thing as white algae?) The fish are fine (white clouds, zebras, and a couple albino cory's is all thats in there right now) and not much of the white stuf on the gravel or rocks.

Any idea what this stuf is? And if it's bad stuf, what do i do to get rid of it?

Water ph is around 7.0 to 7.2 (seems to vary slightly), water hardness is at 5, nitrates and ammonia are nil. Anything else i should test for? Ive been trying to find references to this stuf on the net, but havent found much.

Your help is much appreciated! Im new to all this... and i see there is SO much to learn!

Thanx again.
jazfish is offline   Reply With Quote
Old 12-27-2003, 07:03 AM   #3 (permalink)
Guest
 
Posts: n/a
Default

Jazfish,

Can you pin-point your problem by looking at below website.

http://www.aquaticscape.com/articles/algae.htm

-------------
Regards,
Jay Luto
  Reply With Quote
 
Old 12-27-2003, 07:26 AM   #4 (permalink)
 
Join Date: Dec 2003
Posts: 0
iTrader Ratings: 0
jazfish is a regular member
Default

Hi Jay, and thanx for your response. That is the website that led me here, and is where i got the idea that it is similar to the fuzz algae. But its not green, its white, and it has more of a cottony look to it.

I did a 10% water change and that got rid of some of it. I also gave the plants some fertilizer (leaf zone liquid).

Any thoughts?
thanx,
jaz
jazfish is offline   Reply With Quote
Reply


Aquatic Plant Central > General Interest Forums > General Aquarium Plants Discussions > [Wet Thumb Forum]-Newbie question..help! and Hi! :)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:24 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1