Any Advice? Please!? - New to Planted Aquariums - Aquatic Plant Central

Go Back   Aquatic Plant Central > Welcome Forums! > New to Planted Aquariums

New to Planted Aquariums Don't know where to begin? Find your answer here.

Reply
 
LinkBack Thread Tools Display Modes
Old 10-11-2015, 10:46 AM   #1 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 5
iTrader Ratings: 0
iTugMyTugboat is a regular member
Unhappy Any Advice? Please!?

I have a 30 gallon tank and I really want a vibrant plant tank. What my goal to do is have a tank with a handful of different types of plants and I would like to put a couple rainbowfish in it as well.
I have already bought a good amount of plants without really doing any research and now I feel like an irresponsible pet owner. Good thing the fish havent came in yet...
The plants that I have right now are Dwarf Rotala, Cyperus Helferi, Moneywort, Pond Lily Bulbs, Water Wisteria, Peacock Fern, White Ribbon (just realized these are semi aqautic... gosh I suck). I have a couple others that i forgot to get the names for. I will get them on monday when they reopen. (I think one is a type of cryptocoryne, it has red leaves and comes from a bulb.) Oh I also have some Duckweed in there!

I have an air pump suitable for 80gallons (top fin air-4000) and a 3 stage canister filter from Aquatop (suitable for tanks up to 75gallons). My lighting which I am very not happy with is a National Geographic Customizable LED Lighting Track (2 channels, channel 2 has a dimmer on it) and I have three of the pods set for plant growth, two lunar blue pods, and 4 cool white pods. Now the reason I am quite sad with this fixture is because I have found people talking about not using them for growing plants, just for fish.

I remember now that I have harder than normal water.

I also bought co2 booster from aqueon and some plant food from them as well. I plan to buy a co2 diffuser eventually.

The tank has been set up for about 24 hours now (with plants included) didnt have the extra filter at the time of filling the tank up and adding the decor and accessories. I have noticed that a couple of the plants are already turning translucent or darker.

Oh I keep my thermometer at 79 degrees.

Picture of my tank is attached. Thanks for any input and I will be very grateful for all the help you can provide!
Attached Thumbnails
Click image for larger version

Name:	20151011_144051.jpg
Views:	169
Size:	300.4 KB
ID:	39914  
iTugMyTugboat is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 10-11-2015, 03:08 PM   #2 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 5
iTrader Ratings: 0
iTugMyTugboat is a regular member
Default Re: Any Advice? Please!?

Well it looks like my Vallis. Forgot to put those in the original post, are probably lacking Iron. Also i read that they dont require Co2 so would that mean if i add co2 for the other plants will it harm it? I would imagine not.
They are becoming translucent. Poor things!
iTugMyTugboat is offline   Reply With Quote
Old 10-11-2015, 03:40 PM   #3 (permalink)
Senior Member
 
Join Date: Dec 2007
Location: Near San Francisco
Posts: 2,195
iTrader Ratings: 0
Diana K is a regular member
Default Re: Any Advice? Please!?

Iron deficiency does not hit that fast. Something else is bothering them.
Vals tend not to like the liquid carbon sources like Seachem Excel. They are just fine with pressurized CO2.

The white edged plant is Dracaena sanderiana, not an aquatic plant.
Diana K is offline   Reply With Quote
 
Old 10-11-2015, 09:56 PM   #4 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 5
iTrader Ratings: 0
iTugMyTugboat is a regular member
Default Re: Any Advice? Please!?

Quote:
Originally Posted by Diana K View Post
Iron deficiency does not hit that fast. Something else is bothering them.
Vals tend not to like the liquid carbon sources like Seachem Excel. They are just fine with pressurized CO2.

The white edged plant is Dracaena sanderiana, not an aquatic plant.
Annnnnnd now i have no idea what is up with them then. Could it be the filter? I have some carbon inside the filter. Now taht i think about it, the outlet is right by the one that started turning quickly. I did put my weekly dose of the Co2 booster. Could that also be the issue here?

Once again i appreciate your help!

I would really like to use this hobby for my father and i to have a past time and connect a little more. I know he would love to do this!

Edit: I do realize that the Dracaena Sanderiana isnt aquatic. I have a 10 gallon i will turn into a paludarium with them if thatll work! haha
iTugMyTugboat is offline   Reply With Quote
Old 10-12-2015, 08:37 AM   #5 (permalink)
The Plant Whisperer
 
Zapins's Avatar
 
Join Date: Jul 2004
Location: South VA
Posts: 6,405
iTrader Ratings: 66
iTrader Positive Rating: 100%
Zapins is a valuable member of the community Zapins is a valuable member of the community
Default Re: Any Advice? Please!?

What is CO2 booster? Is it a liquid?

Can you post better close up pics of the plants that aren't doing well?

From your pic I can see that one of them is not an aquatic plant and will eventually die if kept underwater. The white and green striped plant.

Do you have a link to the lights you have?
Zapins is offline   Reply With Quote
Old 10-12-2015, 10:38 AM   #6 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 5
iTrader Ratings: 0
iTugMyTugboat is a regular member
Default Re: Any Advice? Please!?

Click image for larger version

Name:	20151012_142233.jpg
Views:	88
Size:	275.5 KB
ID:	39954

This is my Co2 booster. Yes it is liquid. I returned to the pet store today (local very intelligent and helpful people, always support your local pet store!) and the guy i got the Vallis from said give them a couple more days to see for sure.

I feel like i shouldnt worry too much about the Co2 because i have this http://www.petsmart.com/fish/lights/...6-catid-300073 and i read/heard that the more lighting you have the more Co2 you need. I have bought 3 of these pods http://www.petsmart.com/supplies/lig...t=pfm%3Dsearch in addition to the ones that come with it.

The review i found about these in correlation to planted tanks is this review here http://www.plantedtank.net/forums/10...ht-review.html

Honestly i think i am going to just feel out the situation for about a week or two and see how everything fares. And then go from there.

I will eventually make my own soil for minerals and fert for my plants. Real excited about the post i found for step by step mineral soil. which was originally on this site but i found it here http://www.plantedtank.net/forums/29...on-talbot.html
iTugMyTugboat is offline   Reply With Quote
Old 10-12-2015, 01:17 PM   #7 (permalink)
The Plant Whisperer
 
Zapins's Avatar
 
Join Date: Jul 2004
Location: South VA
Posts: 6,405
iTrader Ratings: 66
iTrader Positive Rating: 100%
Zapins is a valuable member of the community Zapins is a valuable member of the community
Default Re: Any Advice? Please!?

The CO2 booster stuff you are using looks like excel, which is a dilute gluteraldehyde solution. Some plants, like vals, are harmed/killed by it which is probably why they are dying. You can either stop using the stuff and keep the vals or remove the vals and keep using the booster. I personally don't think the booster does much compared to not using it. Its main use is for combating algae, particularly black beard algae.

The lighting you linked may or may not be suitable, I think you'll have to see long term how the plants do. There have been so many LED brand lights recently that it is hard to keep up with reviews and which one is powerful or not.

As for the soil, you can mineralize the soil following that guide or if you choose a soil that is not mainly made of organic stuff then you do not have to mineralize it. Basically if you choose something like scott's premium topsoil that has a good bit of clay/sand in it and some organic matter you probably won't get the ammonia spikes that you see with miracle grow type soils (100% organic manure/compost).
Zapins is offline   Reply With Quote
Old 10-13-2015, 08:30 AM   #8 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 5
iTrader Ratings: 0
iTugMyTugboat is a regular member
Default Re: Any Advice? Please!?

I have stopped using the Co2 booster and i shall see how the vallis look in another day. I didnt use it at all yesterday.

I will probably follow that guide to the T because I have heard from the local pet shop owners that thats what they like to use. And ive always loved their planted aquariums. So vibrant! Its what has sparked my interest!

After about a week (started the tank on the 11th fully up and running) i shall assess my situation and come back and post the update. Thank you all for your help!

I will be back!
iTugMyTugboat is offline   Reply With Quote
Old 11-13-2015, 11:53 PM   #9 (permalink)
Junior Member
 
Join Date: Aug 2015
Posts: 3
iTrader Ratings: 0
Aichmalotizo is a regular member
Default Re: Any Advice? Please!?

I have a 65 gallon tank with jungle val in it. I also dose it with Excel which is another liquid carbon product. When I first placed the val into the tank it had major die off due to the excel, so I stopped dosing for a few days, waited for it to begin growing back, and then began to slowly re-dose with excel. I did a quarter dose for a few days then half, then back up to a full dose and the val grows fine. You just have to adjust it to it.
Aichmalotizo is offline   Reply With Quote
Old 11-15-2015, 09:02 AM   #10 (permalink)
Junior Member
 
Join Date: Jan 2013
Posts: 8
iTrader Ratings: 0
jackal148 is a regular member
Default Re: Any Advice? Please!?

I have a 75 gallon aquarium with Val and I also dose with Excel with no problems. I started using Excel shortly after establishing the tank to combat algae growth. The key to using it is to start out with considerably less that the dosing called for on the bottle and slowly increase. Didn't lose any Val. To the contrary, it grows so rapidly that I have to pull lots of it every 10 days or so to give the fish more swimming room, and to let me see them. The excess doesn't go to waste. A lfs takes as much as I can bring them and gives me store credits or cash. My choice!

Val is very sturdy. Some leaf loss is common do to transplant stress. Once they adjust to their new home, they should set out new leaves. Don't plant it too deeply. Just enough to keep the roots covered and the plant down. Mine run mostly over the gravel with just the roots going down. The actual plant is above the gravel.
jackal148 is offline   Reply With Quote
Reply


Aquatic Plant Central > Welcome Forums! > New to Planted Aquariums > Any Advice? Please!?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:29 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1