Weird growth on plant - New to Planted Aquariums - Aquatic Plant Central

Go Back   Aquatic Plant Central > Welcome Forums! > New to Planted Aquariums

New to Planted Aquariums Don't know where to begin? Find your answer here.

Reply
 
LinkBack Thread Tools Display Modes
Old 11-13-2015, 10:01 AM   #1 (permalink)
Junior Member
 
Join Date: Aug 2015
Posts: 3
iTrader Ratings: 0
Aichmalotizo is a regular member
Default Weird growth on plant

So I got this white fungus/algae/mold growing on bacopa for the past couple of days and murdering it. I already attempted to cut it back, but it just returned. So far it is only growing on the bacopa, ignoring the java fern, java moss, and anubias in there. Anybody got any idea what it is?

Click image for larger version

Name:	IMAG0262[1].jpg
Views:	128
Size:	361.4 KB
ID:	40874
Aichmalotizo is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 11-13-2015, 12:09 PM   #2 (permalink)
Senior Member
 
Join Date: Nov 2015
Location: Maryland
Posts: 287
iTrader Ratings: 0
Tihsho is a regular member
Default Re: Weird growth on plant

It looks like mold growing on dying organic matter. As the leaves are dying (most likely emersed growth) it is rotting and mold is growing over it.

Is it growing on any fresh/new leaves or are the leaves looking rough prior to the white fuzz appearing?
Tihsho is offline   Reply With Quote
Old 11-13-2015, 08:00 PM   #3 (permalink)
Junior Member
 
Join Date: Aug 2015
Posts: 3
iTrader Ratings: 0
Aichmalotizo is a regular member
Default Re: Weird growth on plant

Quote:
Originally Posted by Tihsho View Post
It looks like mold growing on dying organic matter. As the leaves are dying (most likely emersed growth) it is rotting and mold is growing over it.

Is it growing on any fresh/new leaves or are the leaves looking rough prior to the white fuzz appearing?
White stuff appears on leaf then leaf dies and it slowly works its way up. Leaf is healthy and green beforehand. When I originally got it a few months ago the person who sold it to me had grown it submerged, and it grew like fire before this.
That one in the corner was a perfectly healthy topped stem yesterday after I tried to purge it out, was killed overnight.. I used cuttings from these plants to make a little forest in my shrimp tank. They are not suffering the same problem. So at points the plant was shooting up faster than it could melt it down. Wondering if I should just toss it and get a different plant.
Aichmalotizo is offline   Reply With Quote
Reply


Aquatic Plant Central > Welcome Forums! > New to Planted Aquariums > Weird growth on plant

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:26 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1