Aquatic Plant Central

Aquatic Plant Central (https://www.aquaticplantcentral.com/forumapc/index.php)
-   DIY Aquarium Projects (https://www.aquaticplantcentral.com/forumapc/diy-aquarium-projects/)
-   -   Help! DIY LEDs blinking when lit up. (https://www.aquaticplantcentral.com/forumapc/diy-aquarium-projects/108362-help-diy-leds-blinking-when-lit.html)

Tanan 01-11-2015 02:32 AM

Help! DIY LEDs blinking when lit up.
 
Hey guys
I made this LED fixture with 10 cree XPEs, 10 epistar 3W leds. And after running it for a while I didnt use it. Now when I got use of it, I took it out, wiring had came off a few places. So I wired it back and now the LEDs are blinking. I changed drivers, I rewired all LEDs and tested if they work singly. Everything fine, so I connected them to driver and again they blink. What could be the cause? And how to resolve it? I have tried a 600ma constant current driver ( for 12-18 x 3W LEDs). Two 900ma CC drivers (7-10 x 3W leds) and the lights blink with all of these drivers.

TropTrea 01-12-2015 08:07 AM

Re: Help! DIY LEDs blinking when lit up.
 
Quote:

Originally Posted by Tanan (Post 789530)
Hey guys
I made this LED fixture with 10 cree XPEs, 10 epistar 3W leds. And after running it for a while I didnt use it. Now when I got use of it, I took it out, wiring had came off a few places. So I wired it back and now the LEDs are blinking. I changed drivers, I rewired all LEDs and tested if they work singly. Everything fine, so I connected them to driver and again they blink. What could be the cause? And how to resolve it? I have tried a 600ma constant current driver ( for 12-18 x 3W LEDs). Two 900ma CC drivers (7-10 x 3W leds) and the lights blink with all of these drivers.

I had some simular issues with a LED fixture on a slat water tank. What it turned out to be is one bad LED which was a bear to find. The way I found it was removing the LED's one at a time from the circuit and shorting out the wires that would have gone to that particular LED. Eventualy I found the LED wich when removed stopped the blinking.

I investigated the LED that caused the blinking and found that the issue was the star mount was somehow shorted to the heat sink with some corrosion that had built up on the star.


All times are GMT -8. The time now is 10:43 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.