WorkHorse 8, Instant Start Electronic Ballast-2 Available - For Sale or Trade - Aquatic Plant Central

Go Back   Aquatic Plant Central > Other Forums > For Sale or Trade

For Sale or Trade Forum for the non-commercial sale/trade of aquarium plants related goods.

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 06-07-2005, 05:25 PM   #1 (permalink)
 
Join Date: Dec 2004
Posts: 150
iTrader Ratings: 0
SAWALLACE is a regular member
Default WorkHorse 8, Instant Start Electronic Ballast-2 Available

NEW - Fulham WorkHorse 8, Instant Start Electronic Ballast. 2 Available!! If I'm not mistaken they will power 2x96watt PCs or 4x54watt t5s each, among other combinations.

Fulham WH8-120-L Workhorse 8 Ballast Electronic.
Maximum Power: 220 Watts
Maximum Current (120vac): 1.8 AMP
Maximum Current (277vac): .74 AMP
Black/White Wires: 18 Inches
Red/Yellow Wires: 36 Inches
Ballast Case Size: H 1", W 1.72", L 19.25"
Ballast Weight: 14 OZ
Case Quantity & Weight: 25 pcs. 29 lbs.
Full description Here

Asking $25 each plus shipping, way lower than i've seen anywhere. I'll also consider trades.
SAWALLACE is offline  

Advertisement [Remove Advertisement]
Old 06-23-2005, 01:16 AM   #2 (permalink)
Senior Member
 
Aaron's Avatar
 
Join Date: Feb 2004
Location: Hawaii
Posts: 353
iTrader Ratings: 1
iTrader Positive Rating: 100%
Aaron is a regular member
Default

Okay Scott,
This is totally out of character for me but since you've not responded to me I figure I'd throw it out here for all to see.

You got my money, now I'm just wondering where this ballast is. its been almost 2 weeks now. It could be lost in the mail, still at your house, or perhaps it never existed. I highly doubt it would be the latter but since you've been avoiding my inquiries, I can only suspect the worst. So what gives man???

I've been buying and selling things on Aquabid for a while (just reached 100 feedbacks!!!) and I have never been ripped off. This run in with Scott (I'm not completely ripped off yet as there is a small chance that there is a reasonable explanation) is the SECOND TIME I've had problems making transactions on this site. That's just sad. Call me naive, but I'd expect more from supporting member and a sponsor than some 0/0 stranger from AB.

So much for trying to pad my APC Karma by sending people free stuff huh?
Aaron is offline  
Old 06-28-2005, 08:34 PM   #3 (permalink)
Senior Member
 
Aaron's Avatar
 
Join Date: Feb 2004
Location: Hawaii
Posts: 353
iTrader Ratings: 1
iTrader Positive Rating: 100%
Aaron is a regular member
Default never mind my stupid rant!!!

All is cool like the other side of the pillow...

The ballast came today and it seems this was a simple case of SLOW mail!!!! 19 days to be exact! It has never taken this long for anything. BTW, the ballast is in great condition and packed well. Thanks Scott!
Aaron is offline  
 
Old 06-29-2005, 12:17 AM   #4 (permalink)
Senior Member
 
Erirku's Avatar
 
Join Date: Oct 2004
Location: HI, Oahu
Posts: 567
iTrader Ratings: 19
iTrader Positive Rating: 100%
Erirku is a regular member
Default

I too would be worried, if the other party member was not responding to my emails. But as long as they have a good answer for this. Good to hear that you got your mail. But I still haven't recieved my glosso package that was sent out 3-4 months ago. I guess someone else enjoyed it.
REWARD: If found, please notify the recepient and $500 reward shall be given. LOL
Erirku is offline  
Old 06-29-2005, 11:46 PM   #5 (permalink)
 
Join Date: Dec 2004
Posts: 404
iTrader Ratings: 6
iTrader Positive Rating: 100%
SnyperP is a regular member
Default

I think that was my glosso that i sent out to you have never made it! On a side note i sent a package to Holland that never made it either! I'm starting to suspect that one of the postal workers in my area has a interest in aquatic plants! =p

(I've been gone for quite awhile around here, but hopefully back in full swing with a new 20g. RAR!)
SnyperP is offline  
Old 06-30-2005, 01:13 AM   #6 (permalink)
Senior Member
 
Erirku's Avatar
 
Join Date: Oct 2004
Location: HI, Oahu
Posts: 567
iTrader Ratings: 19
iTrader Positive Rating: 100%
Erirku is a regular member
Default

Yup, that was your SnyperP, I bet if you look at the tracking number you gave me, it'll probally say, still in transit. LOL. Maybe someone is secretly stealing your packages? If I were you, I'd go down to post office and send it there, or is that what you do? Then you should make a fake package, with all this bogus algae.
Erirku is offline  
Old 06-30-2005, 11:21 AM   #7 (permalink)
Senior Member
 
JanS's Avatar
 
Join Date: Apr 2004
Location: Hibbing, Mn. USA
Posts: 6,352
iTrader Ratings: 5
iTrader Positive Rating: 100%
JanS is a valuable member of the community JanS is a valuable member of the community JanS is a valuable member of the community
Default

I've had that happen a couple of times lately too. One of the confirmation numbers said it was delivered, but the person on the other end didn't receive it. They had apparently been delivering a bunch of mail to the wrong addresses in that area. It's pretty tough to track it after the confirmation # says it's been delivered.
Another package took about 2 weeks via Priority Mail. Who knows where the stuff gets left sitting half the time...

Sorry, didn't mean to hijack your thread SAWALLACE....
JanS is offline  
Old 07-01-2005, 11:44 AM   #8 (permalink)
 
Join Date: Dec 2004
Posts: 150
iTrader Ratings: 0
SAWALLACE is a regular member
Default

I really don't know what happened with this shipment, perhaps shipping outside the continent is much slower nowdays due to security issues? I also added every shipping upgrade I could (tracking, confirmation, insurance, etc) maybe that slowed it down? Who knows.... I've never really had any problems with USPS until this.
SAWALLACE is offline  
Closed Thread


Aquatic Plant Central > Other Forums > For Sale or Trade > WorkHorse 8, Instant Start Electronic Ballast-2 Available

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Aquatic Plant Forum Replies Last Post
Icecap 150MH electronic ballast tonylau Lighting 3 09-10-2004 12:03 PM


All times are GMT -8. The time now is 07:08 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.6.1