Aquatic Plant Central - View Single Post - Buceplant review | PART 2 | almost 3 years later.
View Single Post
Old 10-06-2020, 04:17 PM   #2 (permalink)
hoppycalif
Moderator
 
hoppycalif's Avatar
 
Join Date: Apr 2005
Location: Brentwood, CA, USA
Posts: 7,415
iTrader Ratings: 22
iTrader Positive Rating: 100%
hoppycalif is a valuable member of the community hoppycalif is a valuable member of the community hoppycalif is a valuable member of the community
Default Re: Buceplant review | PART 2 | almost 3 years later.

I have had very good luck with BucePlants, but not this time. I don't know what changed, but it looks like they are now managed by inexperienced people. First, I ordered a couple of cheap, easy stem plants. It took about 6 days before it arrived, and one of the bunches of plants was just brown gloop in the package. I reported the problem, and they offered credit for a replacement order. So, I ordered a single package of vals. That order took 5 days to arrive, with three of those days spend in my city - Fed Ex delivery. The plants were near dead, but might eventually survive. In all case, the plants were packaged in tight sealed plastic envelopes, very wet. That is not a good way to ship them, in my opinion. When I suggested that it would be chaaper and faster if they shipped by Priority Mail they answered that I had the option of having Priority mail shipment if I wanted it, but they don't offer that option.
BucePlants is in Southern California, about 300 miles from me. A first class mail package would take about 3 days. Priority Mail would take about 2-3 days. Shipping plants works when the plants are damp, but not dripping wet, and if they are in a ziplock envelope with some air, with or without some barely damp paper. BucePlants appears not to know that. I'm through buying any plants from them.
hoppycalif is offline   Reply With Quote