Aquatic Plant Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 46 Results
  1. Algae
    Hi All, I am newbie in planted aquarium. Currently still in fishless cycling stage for 20 days. Mine is Fluval flex Mega 30 gallon tank. I noticed that there are black dots on most of my plants recently. But I am not sure if it is BBA or not. The only difference is I added second Aquasky light...
  2. El Natural
    Hi all, hoping for some advice on some algae that has gotten a foothold in my aquarium. First off, I am a beginner. I went feet-first to a dirted, heavily planted tank after reading (to the best of my non-technical ability) Ecology of the Planted Aquarium (hi Diana thank you, if you read this!)...
  3. Algae
    Hi, Im quite new in the hobby. Started about 1,5 years ago with my 240 liter fresh water aquarium. From the beginning i've had sand as substrate and in the beginning the plants where fantastic and grew rapidly. After 5 month everything changed. Dont know the cause, but at the same time i...
  4. El Natural
    Hello, I am new to this forum so please if this is the wrong place for this post let me know. I am currently having an outbreak in some type of green algae that I have yet to identify. In the book ecology of the planted aquarium, Walstad mentions on page 172 adding water lettuce to the tank to...
  5. Nitrate (NO3) Test Kits
    I bought a Sera NO3 test kit today for my tank (heavily planted, no fish). The test result shows ZERO nitrate (image attached). Then, is zero nitrate good for aquatic plants? Or is it a symptom of Nitrogen deficiency?
  6. El Natural
    Hello Everyone Can you help me? I am very grateful for your resonses In my Walstad tank I am running into trouble with steady algae growth that slowly overwhelms many of the plants. Plant growth is fairly slow and has been for a long time The algae is attached, mostly ½” long and olive green...
  7. El Natural
    Hello Everyone Can you help me? I am very grateful for your resonses In my Walstad tank I am running into trouble with steady algae growth that slowly overwhelms many of the plants. Plant growth is fairly slow and has been for a long time The algae is attached, mostly ½” long and olive green...
  8. El Natural
    Hi all! My tank project is proceeding slowly but steadily. I have a bag of play sand that has sat in the carport for a few weeks while I've been otherwise busy (mineralizing the soil, building lights, etc.) The sand bag was a bit damp from the start, and now it has many brown/green algae spots...
  9. El Natural
    Howdy! I'm brand new to this forum and the Walstad scene. PetCo had their $1/gallon aquarium sale the other day and I couldn't resist picking up a 20 long as I've wanted to do a Walstad forever now. I'm in the planning phase still and I'm trying to understand how to balance the light needs of...
  10. Algae
    I’ve been battling algae for a few years now and sheepishly ask the APC community for their kind assistance. I’ve ready the Sears Conklin article, tried PMDD, tried various test kits etc and still struggle with algae, mostly just plain green algae, but a little BGA and a little hair algae too...
  11. Algae
    I know it's not unheard of when tanks are only a few months old to have an algae bloom. I've been trying to get even a little control of it but to no avail. Background: It started after I added some osmocote root tabs deep under the sand substrate. I pushed the tabs all the way to the bottom...
  12. Algae
    My wife and I have maintained a planted freshwater tank for a couple of years now. Nothing extravagant but it survived with little to no algae attacks. After doing a bit of researching and watching youtube vlogs about tank design and maintenance we decided to upgrade our aquarium to a larger...
  13. Algae
    I had never a time when there was no algae in my tank for the past 8 years! This is the first time when all the algae has just vanished and plants are pearling and growing like they have never thrived before. All these years I used EI ferts, pressured CO2, 6500 K LED light, Amazonia & river...
  14. Algae
    Hi guys, I have been struggling with brown algae for nearly a year now in a 10 gallon low tech that I started. I don't find that I get algae blooms like I did early on, but for months, I clean off my plants, then slowly and steadily, they are recoated in diatoms over about a 2 week period. This...
  15. For Sale or Trade
    I moved and my 72 gallon now gets too much light for my plants to keep up with! Yes, i know moving the tank is an inevitable option- not the easiest task! I'm looking for a CO2 system, or even just the tank and regulator- on a budget. If you have anything available, please let me know. Thanks!
  16. Equipment
    Help please? I've am so confused about my CO2 and Ph levels in my 65 gal planted tank. The more I read the more confused I get. My Ph is a natural 7.8 from the tap and in my tank. I have be injecting CO2 for about 2 yrs now and still can't get it right. I just purchased a CO2 regulator/reactor...
  17. Algae
    Hello, Everyone! I'm relatively new to the hobby and currently battling some issues with algae in my 3 gallon planted betta aquarium that I set about 2-3 months ago. I've tried identifying the species of algae, but I haven't found anything that matches 100% to what I'm dealing with. The closest...
  18. Site Help and Suggestions
    ****IMAGE ATTACHED BELOW****** Hello, I am Sreenath, and Currently I stay in India. Actually the main question to ask you that, I setup a new Planted Aquarium for my home and recently after 3 day I can see Hair Algae all over my Plants. ---------------------Tank...
  19. Algae
    I have a newly established glosso carpet and this green stuff has started showing up about 2 days ago as seen in the picture. The tank is 2 months old and runs ADA set up - 8 hours of light and co2, and fertilizing with ADA Step 1 and Brighty K. ANy advise on how to control and eliminate this...
1-20 of 46 Results
Top