Aquatic Plant Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
I know this all looks like BS. When i found it last time i was setting up, it looked too simple and setup isn't as hard as newbies may think.

However, a friend on another forum used it on a low tech planted and has had spotless water and its been over 9 months since his last full water change. basic maintenance and RO water topup and all is good.

So... my question is, with PPS dosing would this adversely affect my regime or ferts? I'm willing to give it a go to get my current tank water clear. Its only about 2 months in, but water clarity is an issue despite happy fish and plants.

Any thoughts? Experience?

http://www.aquabella4aquariums.com/
 

·
Registered
Joined
·
372 Posts
old water + low fishload is always spotless clean. At the same time the water chemistry slowly deviates from the original water you put in. Some decades ago this was considered the way to go, effectively creating softer water with tannins. It may or may not be appropriate for what you keep in the aquarium, but I don't think that it is nessesary to add anything from a jar to achieve this.

But I have to add that I don't know this product and therefore cannot estimate what kind of miracles it can do.

If your water is not clear, it can be temporary (some bacterial or algae bloom), or there has to be something wrong. Too high nutrient concentration for the plants to take up comes to mind, which could be from fertilizing, soil or fish (either overfeeding or overstocking). It can be difficult to figure out what. It could also be that the main plant biomass seems OK, but consists of mainly very slow growing species, which don't need to take up many nutrients from the water for their normal growth. My first guess would be to start with dosing half less ferts and see what happens.
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #3 ·
Thanks illustrator. The fish load is small, only 4 otos and 5 SAE in a 250 litre. Haven't added my schools yet as I want the tank to be more mature.

I had an issue with algae after a trip away and some overly helpful staff who took it upon themselves to dose the aquarium. A lot! !!

I only just this week started dosing ferts properly and this is half the recommended amount. Plants are responding really well. it should be said that the water has been slightly cloudy for a while. for the last month.

I think it's possibly just bacterial but the last time I had a large volume tank, the same happened. I'm wondering if it's this city's tap water.

Anyway, it's only an 8 week old setup so could still be settling!?

I've bought the product so will try and see what happens when it arrives in a few weeks.
 
1 - 3 of 3 Posts
Top