Aquatic Plant Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
348 Posts
Discussion Starter · #1 ·
I was wondering if anybody else has had a problem with their heater for the TetraTec PF150 heater, model #HC100? I bought my filter and heater together about 2 years ago and about 6 months ago it started going crazy. It would never overheat my tank, but it would never heat it to the temperature I had selected. It would turn on and off at random times. Luckily I keep this tank in my office where I have 3 computers running 24/7, and the temperature is in the mid 70's at all time.

-Dustin
 

·
Registered
Joined
·
6,380 Posts
I've never used that particular brand myself, but I have heard similar reports. I guess it would be a good one to add to our product review section, if it's not already there.

It's a good thing you do have the stable office temps. :)
 

·
Registered
Joined
·
499 Posts
im using the tetratec pf300 with the heater. i have noticed that as time goes it declines in its efficiency to heat, but i have found that once you clean it as gunk will build up on it, that it works very well. try washing it once you notice the water temp drop. it still dosen't do what it claims about warming the water all over. the right side of my 55gal will be 80, and the left side will be around 83, while my heater is set for 84. i just have it set for 84 so i have a decent medium between temps. all temps are F.
 

·
Registered
Joined
·
2,552 Posts
Product has been added to the reviews section.

Those of you with some experience with the heater please enter some comments in the Review area found under the APC Features drop down. The more comments we receive the better the reviews will be for all.

Thanks
 
1 - 4 of 4 Posts
Top