Aquatic Plant Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter · #1 ·
i have a few problems with my plants both algea and fert dif. first the main algea problem is brown algae, i have had my tank set up for a min of 6 months this time. i just cant seem to get the brown stuff to stop growing on the older leafs and some new ones mostly on my large sword though.

now for the nutrient problems first all the older leafs on the stem plants (aramatica,bacopa mostly but a few others) are falling off so i only have the past 2 weeks worth of growth 2-3". on my sword all the old leafs are fine other then algewa covered but the new ones have holes all through the leafs, they almost look like they are being eaten but it is not from the edges but form the centers first so it is not my fish. my star grass grows a bit (1-2") then just stops and slowly gets eaten back or just dies back and then sits that way for 1-02 weeks before it grows a bit again.

al my plants have good color though the sword may be a little pale on the new leafs but old ones are fine. (its the only plant that has older leafs)

now i have a 50g tank, 3.8wpg cpf, pres co2 1 bubble every 1.5sec, we just recently had a new baby so i did not do any wc or fert dosing for 3-4 weeks but i have been dosing normally for 4 weeks and weekly wc now. i add 1teaspoon potassium phosphate 1 time per week, 5ppm kno3 1x week and 5ppm of calcium no3 1x week 3-4 days latter. .5-1ppm kpo4 1xweek now i have test kits but they are all junk and do more harm then good. i dose 20ml of both botanical micro and grow on wc and then another 10ml of both 3-4 days later with 5ml of plantex mixed at 1 tablespoon-250ml water, 1ml seacheam fe week and then my ph stable for KH and 25ml liquid calcium and 1.5ml epsonsalt for GH this all 1x a week. i hope i have added everything needed. i will try and get ahold of a camera tomorrow and take a few pics as well.
 

·
Banned
Joined
·
2,069 Posts
now i have a 50g tank, 3.8wpg cpf, pres co2 1 bubble every 1.5sec, we just recently had a new baby so i did not do any wc or fert dosing for 3-4 weeks but i have been dosing normally for 4 weeks and weekly wc now. i add 1teaspoon potassium phosphate 1 time per week, 5ppm kno3 1x week and 5ppm of calcium no3 1x week 3-4 days latter. .5-1ppm kpo4 1xweek now i have test kits but they are all junk and do more harm then good. i dose 20ml of both botanical micro and grow on wc and then another 10ml of both 3-4 days later with 5ml of plantex mixed at 1 tablespoon-250ml water, 1ml seacheam fe week and then my ph stable for KH and 25ml liquid calcium and 1.5ml epsonsalt for GH this all 1x a week. i hope i have added everything needed. i will try and get ahold of a camera tomorrow and take a few pics as well.
If you are losing leaves, then you are likely having CO2 issues.
You need to do a pH/Kh test to measure the CO2 with the pH/KH/CO2 chart, shoot for 20-30ppm durning the entire photoperiod.

You need to add abiout 1/8" teaspoon of KH2PO4, not 1 teaspoon) 3x a week or so. KNO3 needs added at the rate of 1/2 teaspoon 3x a week. Why are you adding Ca(NO3)2? Are you low on Ca? What's the GH? Well you do not need such a mess of stuff all going in at different times and volumes etc.

This will not balance things better, it will complicate them .................

You need to work on the CO2 first and foremost.
Do not do anything till you get that dealt with.

You have a lot of light and the plants will need more nutrients and more frequent dosing.

I'd simplify things personally.

Dose 3x a week or every other day.

KNO3: 1/2 teaspoon
KH2PO4, 1/16 teaspoon
Traces: use the general trace for plants 15mls

Ca/Mg(GH), Baking soda(KH) added on the water change day.
CaCl2 is easy to dissolve and will not influence NO3 levels.

You can use RO right or SeaChem Equilibrium also, about 1/2-1 teaspoon after a water change will be fine.

You can dose this routine 3x a week or every other day, withb the macros being dosed after the water change and the traces on the off days.

That should simplify things and dosing for you.
Weekly 50% water change, use a python etc to make it easy on yourself.

Regards,
Tom Barr
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #3 ·
ok i got some better test kits for KH/GH and PH my KH was 50ppm and ph was 7.0 thats a wopping 9ppm co2 not enugh so last night i uped my co2 and KH i now have 70ppm KH and 6.8PH so i have 19ppm co2 i just turned my co2 up again so i wil probally be at 25-30ppm by tomarow.

my tap water is extramly soft. like 10-20 ppm kh/gh so thats why i add stuff. the PH stable from kent i use is basically the samething as baking soda just more concentrated and last a bit longer. you sudjested useign equalibrium for GH i wil give that a try when i run out of kent liquid calcium. someone a few mons back sudjested to use this stuff and epson salt combined for GH it has worked so far pretty good and i only have to ad dit 1x a week. nice and simple.

now for the rest of the fertilizing i guse i nee dto do a 50% WC befor i can really start that rutine. have you had much use with plantex? i am only useing it to help keep the cost of the botanical stuff down but that is not a big worrie to me.

1 week ago i dosed all my micros real high i did not see any change until 1-2 nights ago the plants startded to pear a bit acually (befor i turned up my co2) i had not put any micros in for 3-4 days by this time is that normal? also i fi start useign just the botanicla micro and grow it says to use 5ml per 10gal 1x a week of each. i was puttign in 20 of each whe i did a wc and then anopther 10 later in the week do you think that is enough or sould i average it out a bit more?

for the NPK thank you for the help so far i think i just need ot play around with that part now for a bit :roll:
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #4 ·
i got a pic of whats happunging to my sword plant. it has beena few days with the new fert rutine, i have a new leaf that you cant see in the pic but it is startign to do the same as well.



here is what the tank looks like. i kow it is of a poor quality i dont have a digacam of my own so i dont knwo how to work it the best:(
 

·
Banned
Joined
·
2,069 Posts
Things are not going to suddenly change over night. You need to provide the plants with good ranges of nutrients and do the water changes and prune off old ugly leaves little by little.

You need to keep the CO2 up and keep it there.
You need to dose KNO3, KH2PO4 3x a week at least
You need to add KH/Gh at the water changes only(shoot for5 degrees GH, 3 for KH)
Do 50% weekly water changes.

Prune and clean filters. Then do a large weekly water change right after. Add nutrients and go from there. As newer growth appears, trim off infested old leaves. If a leaf is heavily covered, remove it from the start, don't wait, it's no good at that point.

If you feel you'll have nothibng left, save some leaves on a plant, but new growth will appear with good CO2/light/nutrients.

Might take 3-4 weeks to get things back to the way you want them.

Regards,
Tom Barr
 

·
Registered
Joined
·
57 Posts
What kind of fish do you have?

my star grass grows a bit (1-2") then just stops and slowly gets eaten back or just dies back
Just wondering because some of those plants look like they've been chewed on. Any Clown Loaches in there? I've had them punch holes in the new leaves of sword plants before. Also, Florida Flags seem to really enjoy stargrass.
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #7 ·
no clowns, i have 2 large angels i think they lie to eat the stargrass, i also have 1 german ram, a few fire red barbs(never seen them go after plants yet just each other) cardonals, a 4-5"SAE, corries, 3 zebra loaches, 1 otto(i need more) an di just got some form of a dwarf placo 1 week ago it is 1.5" long right now and has white dots all over it. i was told it dos ento eat plants. i also had all my plants being eaten befor i added it.
 
1 - 7 of 7 Posts
Top