Aquatic Plant Forum banner
221 - 222 of 222 Posts

·
Registered
Joined
·
3 Posts
Hi there,
I was hoping you could offer some advice for the following tank setup:
Tank: Juwal Rio 240 litre
Lighting: Fluval fresh& plant 2.0 (4.30pm to 5pm ramp up to 80% - 10pm to 10.30pm ramp down)
Co2: Pressurized 3bps (4pm to 9.30pm) mixed with internal co2 reactor.
Tank type: heavily planted jungle tank (Sords,crypts, red lotus, xmas moss etc)
Filter: All ponds solutions efx+ 2000 l/ph
Dosing :uk plant food uk ei dosing

The problem:

I am following your recipe and dosing schedule to the extent of dosing for a 200 litre tank not for the full 240 litre which my tank is. All algae seems to have disappeared, but green spot algae has taken hold on my crypts, swords, aubias and some of the other species and also my red plants dont seem to be as vibrant with stunted and small leaf growth. But only specs on the glass hardly worth worrying about.

I did do i phosphate test, it indecated 40ppm which i dont think is right so i take those results with a pinch of salt.

Any advice hear?

Do I need to dose for the full 240 litres because I am under dosing? Is this a deficiency overall throughtout my tank?
I'm wondering that too.

Great overview! I'm sure I'll be referencing this thread often.. Very simple to understand.

75 Gallon Fish Tank
 

·
Registered
Joined
·
22 Posts
You only need about 1ppm of phosphate. I once has phosphate that were at least that high is not higher. It was caused by a nutrient deficiency. Once I fixed the deficencyphosphate level came down and stabilized.pants were only able to consume a very small amount of the Phosphate I was adding. Stunting might be caused by a boron deficiency. Small leave might be caused by low Zinclevels.

Plant food UK micro nutrient package looks like it is the Casic CSM +B recipe Basically they buy the EDTA ingrediients from a company and add boron. It is the most popular micro nutrient. But I has 2 basic problems Iron EDTA at a PH above 6.5 turnstone iron oxide which is not soluble in water and not usable by plants. The other problem is that it doesn't have enough zinc. Since I learned that I took my CSM+b which didn't work in (my tank)and addd Fe DTPA (good to a PH of 7.5 and doesn't fully oxidize until the PH reaches 8. And I used the zinc from 0.001ppm to 0.02 PPM. It works now. GLA has also done this with their CSM +B Product(link) it might work better for you.

Also the original EO recipe didn't have any recomendationts for sulfur, calcium, magnesium. All vital macro nutrients. Also there was no speck for the micro nutrient Chlorine. Normally tap water is treated with Chlorine to sterilize it. So most tap water has abundant levels of chloride salt. But if you are using DI or OR water you won't have any. So Keep these nutrients in mind if the GLA micro mix doesn't solve your problem you may have a macro problem
 
221 - 222 of 222 Posts
Top