Aquatic Plant Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter · #1 ·
So I've town down a tank due to this algae once before, and it's come back.





It seems to grow in large filamentous tufts. Very fine (virtually invisible) filaments extend out from the tuft and weave their way around everything.

The last time I had this algae it jammed my eheim impellor, and what looked like a couple isolated tufts had actually weaved strands throughout my entire HC carpet.

Here's the kicker, I've been spot treating the tuft in the pictures with hydrogen peroxide daily for over a week. It's happy as ever.

Any ideas?
 

·
Registered
Joined
·
468 Posts
Discussion Starter · #3 ·
Don't have any Excel unfortunately. I could get some, but I'd have to order it online, and that's a bit expensive for an experiment which may or may not do anything.

There's no fish in the tank though, and I'm sure there's plenty of tiny filaments woven around in places I can't see. Ideally if there's anything I can dose into the water to target it... Even draining the tank and giving it a thorough spray/soak with some sort of algicide, flushing out all my equipment, etc.
 

·
Registered
Joined
·
468 Posts
Discussion Starter · #5 ·
Yup, clado was my best guess.

I can remove it manually, but it seems to do a number on my hair grass every time I do.

I'll do some research and see if I can't figure something out unless anyone knows plant-safe algaecide that'll touch this stuff.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top