Aquatic Plant Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Can anybody tell me what this brown furry looking growth is? It seems to be taking over! I am somewhat of a noob to the live planted aquarium and not sure if this is normal?! :confused:

The tank: 14 biocube
co2: using fluval 88
I have been using fertilizers from Flourish: Comprehensive Supplement (about 3-weeks)
Just started using a Nitrogen and potassium supplement today with guidance from the LFS
lighting aprox 9-10 hours a day (Stock lighting came with Bio-cube)

Fish: 4 rummy nosed tetras, 2-miniature corydoras, 6-ghost shrimp and 1-zebra snail.

Thanks



 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
It's ALGAE! ;)

Okay, Flourish Comp is micro-nutrients only, juts FYI. Which "Nitrogen and Potassium supplement" did you get? And what about Phosphorus? You might not even need ferts at all, depending on your light.

The light is the stock that came with the cube, how many watts is it and what kind of bulb (curved thin tube (PC) or straight bulb (t-5 or t-8 ), etc... )? And what substrate are you using?
Lighting: Standard 10,000k 24watt and I don't use the corral light.. Or should I? its actinic 24watt.

Fluval Stratum Substrate

I am also using a fluval-88 co2 injector.

Fertilizers (not shown is the comprehensive supplement)

 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top