Aquatic Plant Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
This sounds stupid, but I can't grow java moss, this is supposed to be a EASY plant. I have put it in my high light (nearly 4w/g, W/ pressururized co2 30PPM) I put it in a low light (30 tall show tank 65W PC 12 PPM co2) I put it in the 3W/G 50G tank with 25PPM co2, and the "walstad" tank w/ no ferts or co2. It just seems to wither away and die. You can see a pic of two of my tanks here,
http://www.aquaticplantcentral.com/forumapc/showthread.php?t=4674

http://www.aquaticplantcentral.com/forumapc/showthread.php?t=4662

Perams, commen to all tanks, kh 120PPM, PH 7.0-7.8 (depending on the tank's co2 level) amm = 0, nitrite = 0, phospate = 1, nitrate = 10, all ferts dosed macro/trace amount depends on plant groth/light/what makes no algae. Water is med-hard.

Is there somehting I don't know?? I have tried moss from diffrent suppliers, does anyone have any hints?

Thanks,
Whiskey
 

·
Registered
Joined
·
6,380 Posts
Did it look healthy when you got it from the different suppliers?
I know when I first ordered some it came in in poor shape and never recovered. I later got some nice green healthy stuff from a friend and it's been keeping me well stocked since then, to say the least. :)
 

·
Registered
Joined
·
204 Posts
I had the same experience as JanS. I bought some from the LFS and it looked poor and never came around in my very healthy tank. I got some later on from an employees there and it was very healthy. I had massive clumps of it that needed constant trimming for over two years. I later gave it away though, since it was tangling itself in my impellers in the filter. You may be able to find some healthy java moss here if you ask for it in the for sale/trade section.
 
1 - 3 of 3 Posts
Top