Aquatic Plant Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter #1 (Edited)
I just started dosing pfertz every other day (only dosed once micros, nitrogen, potassium) And today is fertilizing day so i go over to fertilize and this is what i see.

Its an anubias and i've never had problems with it before



My tank specs are
10 gallon
27 watt desk lamp from home depot (temporary till the lights i want get instock)
RO water with some equilibrium and alkaline buffer added
no ammonia or anything like that
this is in the red flourite substrate
 

·
Registered
Joined
·
209 Posts
With pfertz I believe you are supposed to dose one squirt of each N, P, K, and micros for each 10 gallons (or 5 gallons if you got the new concentrated formulas). The idea with pfertz is that it provides just enough ferts for the plants to get by, so by dosing every other day, the plants are basically getting nothing for an entire day. That combined with a desk lamp might have something to do with it...
 

·
Registered
Joined
·
2,074 Posts
Have you recently moved it? It likely is just losing a leaf, though if you just moved it, you may have damaged the rhizome. It could be that it is adjusting to the fert. regiment.

One possibility is that you are adding too many ferts for a slow growing plant like anubias to handle. If this is a tank with slow growing plants, you may want to back off a little bit on the ferts. This does not look like an "under-dosing" problem to me, and is likely that the rhizome may have been moved recently or it is buried too far in the substrate.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #4
i just replanted it as i had to dunk in peroxide (guess i forgot about that) for hair algae. my pfertz bottles say 1 pump every other day for ten gallons or one pump per twenty gallon daily.
 

·
Registered
Joined
·
2,074 Posts
I think that you found the problem, Mary. Abubias is not fond of being moved and replanted. If the leaf was already damaged prior to the peroxide treatment, then the peroxide likely exacerbated the problem. Just snip off the bad leaf. Continue to dose with pFerts as you have been.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #6
ok thanx :D
 
1 - 6 of 6 Posts
Top