Aquatic Plant Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
I checked my nitrates a few days ago and they had shot up to a breath taking 20 ppm. Phosphates were at 2. My question is, why arent the nitrates being taken up? What could the tank be deficient in to not allow nitrate uptake? I have a hunch it may be my soft water. I havent added any egg shells for calcium lately. Could this be my problem? I am also dosing mgs04 via epsom salts. All the other macros and micros are going into the water as normal. My gh has never been over 1 degree, and my kh is 5 at its highest, and 3 at the lowest. I dont notice any plants dying or fish sick, but I have noticed my plants are in a stunted state. After a 20 percent water change, I got my nitrates back down to 10 and phosphates I lowered to 1 for now. 10 gallon with 3.6 watts of pl light.

Thanks for your help

Otis
 

· Registered
Joined
·
91 Posts
Discussion Starter · #4 ·
Ok ca and mg is the only thing im not adding as regularly as I am traces, no3 and p04. I guess I will have to wait until the eggs get into the water. Im sure I will see things perk up from there. Whats the quickest way to get calcium in the water? The only plants that are looking kinda weird is a few stems of my cuba. Everything else is great but in a stunted stage. My macrandra is also doing something ive never seen it do before. Its growing very short, and branching off like crazy. Its basically turned into a big macrandra bush that wont grow upward. But its red as red can be.

Thanks for the help guys

Otis
 

· Registered
Joined
·
91 Posts
Discussion Starter · #7 ·
hmm, now that I think about it, I didnt put the sponge back into my co2 reactor. Perhaps too much c02 is escaping from the chamber? I didnt think to check my c02 levels as I am running two 2 liter bottles into a 10 gallon. The last time I checked it(with the sponge in), it was around 25ppm. I will check it again tonight and see if its dropped. I will go pick up a bottle of equilibrium tomorrow and see how that goes for me.

Thanks all :D

Otis
 

· Registered
Joined
·
91 Posts
Discussion Starter · #10 ·
Well good news. I turned on my lights today at first to see the same looking plants. About 2 hours later, things are looking much better. My hairgrass is returning to its deep green state, my cubas sprouts seem to be starting to take off from the stunted state, and my stargrass is losing the whiteness in the leaves. I didnt imagine things would turn around this fast but it seems so. I think the turning point was the egg shells being re added to the tank.

The only plant that im having a problem with now is pearlgrass. However its been this way for a while(long before the other plants) The pearlgrass tips are transparent almost and look like theyre dying. However, new shoots are coming on the stems and the lower parts of the stems are green. Ive never seen this before, especially not in an easy to grow plant like pearlgrass. Anyone else had this experience?

Thanks again

Otis
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top