Aquatic Plant Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
323 Posts
Naomi, I got a bunch from Guy during last plant swap. They have been growing runners like crazy, similar to chain swords. They are actually somewhat shaded by taller plants. It is a really easy plant. I suspect nutrient problem in your tank, not sure what from your dosing schedule. Do you have really soft tap water? That might be a problem, you might need to add Ca/Mg. If your other plants don't have twisted/bent/stunted leaves, then I suspect more of a Mg problem than Ca problem.
 

·
Registered
Joined
·
323 Posts
gnome said:
After Sha's post, I decided to add some epsom salt. I'll see if this does anything. I checked the GH before-hand and it was 8 degrees. Of course I have no idea how much is contributed by Ca vs. Mg, although I have been adding some gypsum and epsom salt at a ratio of 2:1 to the change water. Out of the tap, the GH is 4-5 degrees.
In that case, I doubt it is Mg then, you don't need a lot of Mg. don't know what it is.

gnome said:
I guess this plant hates me, too (along with all red plants and most green ones :rolleyes: ). Oh, and Greg - thanks for the offer for some "backup." I may take you up on it. I'll let you know before the next SFBAAPS meeting.

Thanks, All!

-Naomi
I am sorry so many plants seem to hate you, but don't give up. Keep giving them TLC and one day they will appreciate it. I can back you up too. I am sure pretty soon I will have more than I know what to do with.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top