Aquatic Plant Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
Here's what my tank looked like before:


This is what I was dosing and it seemed to be working pretty well:

29 gallon tank. 3.3 watts per gallon. Pressurized Co2.

Friday............ Add 1/4 tsp KNO3, 1/64 tsp = KH2PO4, 1/8 tsp = K2SO4, 1/16 tsp = Iron 10%
Adding this amount to the tank - (NO3=7.25 PO4=0.55 K=8.05 Fe=0.27)

Saturday...........Add 1/16 tsp CSM+B, 1/32 tsp = Iron 10%
Adding this amount to the tank - (Mg=0.03 Fe=0.30)

Sunday.........Add 1/4 tsp = KNO3, 1/64 tsp = KH2PO4, 1/8 tsp = K2SO4, 1/16 tsp = Iron 10%
Adding this amount to the tank - (NO3=7.25 PO4=0.55 K=8.05 Fe=0.27)

Monday....Add 1/16 tsp CSM+B, 1/32 tsp = Iron 10%
Adding this amount to the tank - (Mg=0.03 Fe=0.30)

Tuesday........Add 1/4 tsp KNO3, 1/64 tsp = KH2PO4, 1/8 tsp = K2SO4, 1/16 tsp = Iron 10%
Adding this amount to the tank - (NO3=7.25 PO4=0.55 K=8.05 Fe=0.27)

Wednesday.............Add 1/16 tsp CSM+B, 1/32 tsp = Iron 10%
Adding this amount to the tank - (Mg=0.03 Fe=0.30)

Thursday.........50% water change = Rest day

Now I have sold most all my Sagittaria, half my Belem's, Most of my Hygro Sunset, 2 large sword plants, most all my Limnophila sessiliflora.

Now I am going to be stocking my tank with Crypts and a couple other that are considered slower growing and lower light then the plants I had before.

Should I lower my Fertilizer dosing or should I leave it the same?
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #4 ·
ok cool, thanks. :hippie:
I will be heavily stocking my tank again in about a week.
I was worried that with slower growing plants, I wouldn't be absorbing nutrients the same way as I was before and I didn't want too much ferts in my water for algae to start growing.

I was testing out what plants I like and learning how they grow while trying to balance my tank.
Now its time to aqua scape into something that looks good :cool:

My Belem's seem to be the best growing plants in my tank.
I got some Belem's with 4 and 5 crowns on 1 stem [smilie=k:

[I]1 Stem[/I]
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #5 · (Edited)
I forgot to mention that my water is green and cloudy...
I'm thinking I'm dosing too much? My plants are growing out of control.
There is only a super tiny bit of BBA on some spots, and a Super teeny tiny bit of thread algae on my Phoenix moss.

I thought I was supose to dose to give my water sertain levels of each nutrient, but I think I really might have ot much going on. WHat shoudl I adjust my nutrient numbers to?

I really have no clue, the only way for my to tell when I have to much or too less is when I get a problem with algae or green water.

Pulling apart my tank is why it looks like this:

 
1 - 5 of 5 Posts
Top