Aquatic Plant Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
I just set up a 10 gal shrimp tank that I plan on putting RCS in to start out with. I was wondering how long I should wait until I put them in there. I used some water from my other tank and am also going dip one of filter pads in it to get some bacteria in here. I also used Eco complete. Thanks for the help.
 

·
Registered
Joined
·
414 Posts
if you can leave the filter pad in the tank. Most the bacteria is on the surfaces so using water doesn't do much to start a cycle. You adding plants? What kind of filter do you have on it?

I would recommend waiting at least a month, two would be better. If you add some plants you will probably get a nice brown diatom algae when its ready for shrimp
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #3 ·
Yeah I added some bylxa, ludwiga repens , and some bacopa moneri from my other tank. The filter is just HOB that came with the tank as I bought it as a kit. Just a top fin 10. wow didnt realize that long.
 

·
Registered
Joined
·
816 Posts
if you have filter media in the tank, you can get it in in about two weeks. I actually put the filter from my main tank into the one shrimp tank (swapped filters) and had shrimp in immediately no ill effects.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #6 ·
I will probably just wait a month or since I am leaving for a week in the middle of december. Will start it when I get back thanks for the help
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #8 ·
Thats what I am doing. I set it up last week with plants and filter and everything. Im thinking about putting a few feeder guppies in there to help do you think i should or just let it go
 

·
Registered
Joined
·
910 Posts
i used 10 gallons of seasoned water along with a filter from a 10 gallon HOB filter to start my tank and never had any ammonia spike. Then again from day one i was heavily planted with ludwiga, java moss, hydrocotle, baccopia as well as a few plants that i dont know their id.
 

·
Registered
Joined
·
36 Posts
that is exactly what he means. i did it, and had an ammonia spike several weeks after planting, which i quickly remedied by adding purigen and doing frequent water changes.

the mulm really sped up the cycle for the tank, i used eco complete, and it should work just as well for you!
 
1 - 12 of 12 Posts
Top