Aquatic Plant Forum banner
1 - 9 of 9 Posts

·
Premium Member
Joined
·
8,540 Posts
Discussion Starter · #1 ·
I think I have some stunting going on. I recently upped the lighting in this tank to two 24W fluorescents. It's in a stock hood. Look at my 10g shrimp tank under my sig. for the lights in that thread. The plant is in that tank. I have cut down on dosing KNO3 since I put CRS in the tank. I still does phospates, and potassium. I haven't put much iron in it either. Had a recent issue running out of CO2 as glass diffuser plugged. That is fixed. So what do you think is going on? A combo of all preceeding issues? What do I try to fix, add.... Do you think I have TOO much light?

Ludwigia sp. "Guinea" aka Ludwigia senagalensis
 

·
Premium Member
Joined
·
5,865 Posts
Ludwigia senegalensis loves nutrients. How much did you cut down on the nutrients you were adding? Changes all of those variables at once makes it difficult to determine which one is making the difference.
 

·
Premium Member
Joined
·
8,540 Posts
Discussion Starter · #4 · (Edited)
I will increase iron. I was being stingy. I had really cut the KNO3. I am EI dosing the P and K. Was worried about the CRS with the Nitrate. Should I do a small amount of KNO3. Regular dosing calls for 1/8 tps. I cut back to 1/32 tsp which is only 25% of regular dose.
 

·
Premium Member
Joined
·
5,448 Posts
FWIW, I have not seen any issues with my red cherries with NO3 levels in the 10-20ppm range.
 

·
Premium Member
Joined
·
5,865 Posts
Perhaps you could try dosing daily instead of dosing EI? I've never kept CRS so I can't speak from experience as to their sensitivities.
 
1 - 9 of 9 Posts
Top