Aquatic Plant Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,710 Posts
Discussion Starter · #1 ·
I have some dwarf chain sword and something else that isnt doing so great. I may not have enough light for them, I dont know. My tank is 75gallons, 2 watts per gallon flourescent, I dose 4.1grams KNO3, 2mL fleet enema, and 15ml Flourish. Each twice a week. These plants have been in the tank about a week. Any ideas?






Does anyone know what this plant is?

TIA
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter · #7 ·
All the pics I see of Rotala rotundifolia look a whole lot better than mine. Granted I have only had it about a week, but should I cut off the tops and replant them? There are no leaves on the lower portions of the stems.

TIA
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter · #9 ·
Thats pretty much what I have attempted to do. The only plants that I think are not fast growers are the dwarf chain sword, c. wendtii, and anubias nana. The two photos above and the c.wendtii in the crypt forum are not doing so well, but I have only had them a week so they might just need more recovery time. They were all in sad shape when I bought them.
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter · #11 ·
Im sure I probably need more plants then. My LFS wont be getting any more for about a week and a half :-( Guess I will be stuck waiting. Anyone know of a really cheap package deal with lots of fast growing plants?
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter · #14 ·
I believe both of these plants were in immersed form when I purchased them. They are both shedding old growth and growing new, different leaves. The dwarf swords spoon shaped leaves are dying and new narrow blades are coming in. :)
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top