Aquatic Plant Forum banner

1 - 20 of 64 Posts

·
Registered
Joined
·
65 Posts
Warm white bulbs for a planted tank...I had a really bad outbreak of BBA that I attribute mainly to them. I switched them out with aquarilux bulbs. They are cheap, provide proper spectrum, and can be found at most hardware stores.
 

·
Registered
Joined
·
40 Posts
Totally useless Red Sea PO4 and Fe test kits. I never got a decent reading from either kit despite having reference solutions that were in the middle of the kits' ranges where they should be most accurate. Swapping for new kits didn't change anything.
 

·
Registered
Joined
·
274 Posts
I dont remember the name of this (supposedly algae eating) fish. It's huge and it's mouth is formed to suck on things. I bought it at an lfs(tong's) for $24 bucks with a two day guarantee. It didnt' even eat a single bit of algae(any type) and died on the beginning of the third day.
 

·
Registered
Joined
·
105 Posts
Man, I really like my Fluval canisters... Never had a problem. Are you guys playing football with them?!

Anyway-- worst thing I ever bought (besides a 30" aquarium) was a product called Aquarium Plant Vital which was upposed to replace CO2. This was WAY before Excel which I hear works well. I think it was a Mark Weiss product...Snake oil, it was totally worthless, IMO.
 

·
Registered
Joined
·
179 Posts
Emperor 400 ??? I love my bio-wheel, I think they work well besides the priming problem, but only good for fish tanks.
The worst filter I brought was the Whisper 3.
Besides that the JBJ algae magnet and the JBJ 2 way powerhead is also on top of my worst list and of cost the plastic plants.
 

·
Registered
Joined
·
811 Posts
ryuken168 said:
Emperor 400 ??? I love my bio-wheel, I think they work well besides the priming problem, but only good for fish tanks.
Exactly Ken.
I was giving my review from plant-geek perspective. Works like a charm on my Malawi Lake tank, but counter-productive in planted tanks.
 

·
Registered
Joined
·
739 Posts
For me it has to be AmQuel, after more than 10 years of using Tetra Aquasafe for some stupid reason I decided to give AmQuel a shot. Killed all my apistos and rams in one day :-(

Disclaimer: it was obviously due to heavy metals in my tap water than AmQuel is not supposed to fix. Perhaps that was the most "stupid" purchase come to think of it :)

Giancarlo Podio
 

·
Registered
Joined
·
20 Posts
tap water purifier...

when I first started keeping a tank I thought it would help with my liquid rock. I should've invested in an ro unit instead. I ended up tossing it when we moved. It was a pain and I had to change the inserts constantly. thanksfully I have wonderfully soft water now. Now all I have to do is add baking soda to keep the kh up!
 

·
Registered
Joined
·
4 Posts
I have used plenty of Red Sea test kits, P04 always worked great. Fe never worked great..... I wonder if it's operator error? Perhaps the color charts were read wrong or something......

Worst thing I ever bought was glass tops made by Hagen, specifically the ones for non-centerbraced tanks, with thier own plastic centerbrace...
 

·
Registered
Joined
·
302 Posts
Whats so bad about Whisper filters? Im guessing its cause they are HOB?

I've got an emperor runnign on my 46 gallon bowfront. Even if you arent injecting Co2, is that a bad thing?
 

·
Registered
Joined
·
302 Posts
My stupidest purchase was a canister filter that had a clip missing..... being a canister virgin, i had no idea that it would leak A TON of water into my house.....fellas if you are going to buy a canister filter used, make sure it has all the clips!!!! the dishonest seller might not even warn you about it!!!!
 
1 - 20 of 64 Posts
Top